debianにFirefoxをインストールしようとしたらエラーになった

Firefoxの公式サイトから、Firefoxのbz2ファイルをダウンロードして解凍し、Firefoxを実行したらライブラリーのエラーになった。なんで??

調べてみたら、単純にdebianにia32のgtkライブラリーが足りていなかった事に気がついた。あ、そうか64bitだっけ。
このライブラリーはいつも通りapt-getで簡単にインストールできた。驚いた。